1. Lieber Besucher,

    wir dürfen Dich in unserem Webhosting-Forum herzlich begrüßen.

Problem mit LetsEncrypt-Zertifikat

Dieses Thema im Forum "Virtuelle Server (VServer)" wurde erstellt von boerge, 24 Mai 2017.

  1. boerge
    Offline

    boerge Neues Mitglied

    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Hallo zusammen,

    ich hoffe mir kann hier geholfen werden…bin am verzweifeln. Ich habe einen HE VirtualServer (Ubuntu12 / Plesk 17), mehreren Domains und die LetsEncrypt-Erweitung installiert.

    Das Problem besteht nur mit einer Domain:

    ruft man die Seite über „domain.de“ auf, ist alles Paletti … versucht man es mit www.domain.de blocken die Browser den Zugriff („Diese Verbindung ist nicht sicher“/ „SSL_ERROR_BAD_CERT_DOMAIN“).

    Wenn ich bei LetsEncrypt das Häkchen vor „Include a „www“ subdomain for the domain and each selected alias“ setze erhalte ich folgende Fehlermeldung: „Challenge marked as invalid. Details: Invalid response from http://www.domain.de/.well-known/acme-challenge/rJK_pLy7quNWQsmucYd3hksEnRnmhAnl1fk2ds3cF6s: "<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <html><head> <title>404 Not Found</title> </head><body> <h1>Not Found</h1>"

    Bitte dringend um Hilfe, uns springen rund die Hälfte der Besucher sofort wieder ab.

    Vielen Dank, Jörg
     
  2. Bitpalast®
    Offline

    Bitpalast® Premium Webhoster

    Beiträge:
    124
    Zustimmungen:
    17
    Punkte für Erfolge:
    33
    Vermutlich ist an einer oder mehreren dieser drei Stellen eine Umleitung auf die Nicht-WWW-Schreibweise der Domain eingerichtet:
    - Im Plesk Panel in den Hosting-Einstellungen als "bevorzugte Domain"
    - In einem Content Management System, z.B. Wordpress, als Default-URL
    - In der .htaccess-Datei der Website als RewriteRule
    Dadurch kann die Let's Encrypt Software die Challenge nicht testen (sie wird immer zu einem anderen Speicherort umgeleitet, wenn sie den Aufruf versucht) und antwortet mit dem Fehler.

    Entfernen Sie die Dauer-Umleitung von www auf nicht-www, dann kann auch das Zertifikat für den www-Teil installiert werden.
     
  3. boerge
    Offline

    boerge Neues Mitglied

    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Vielen Dank für die Antwort,
    -Plesk-Hosting-Einstellung steht auf non-www
    -Wordpress-URL (unter Einstellungen - Allgemein) steht auf https://domain.de
    -die .htaccess hatte ich bereits entfernt bzw. mit einer Rewrite-Rule von www zu non-www versehen

    Noch andere Ideen?
     
  4. Bitpalast®
    Offline

    Bitpalast® Premium Webhoster

    Beiträge:
    124
    Zustimmungen:
    17
    Punkte für Erfolge:
    33
    Sie haben den Grund ja selbst genannt. Sie versuchen, ein Zertifikat für www.domain.de zu erstellen, erzwingen aber den Aufruf mit domain.de, d.h. ohne den www-Teil. Dadurch kann die Let's Encrypt Extension die Authorisierung für die www.domain.de nicht ausführen. Wenn Sie auch www.domain.de verschlüsseln wollen, müssen Sie zunächst in Plesk in den Hosting-Einstellungen die "bevorzugte Domain" auf "keine" stellen.
     
  5. boerge
    Offline

    boerge Neues Mitglied

    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Das macht absolut Sinn...nur habe ich jetzt durch zu viele Versuche das RateLimit erreicht, d.h. LetsEncrypt aktualisiert das Zertifikat gerade nicht. Ich geb in 7 Tagen nochmal Rückmeldung obs geklappt hat.

    Herzlichen Dank!
     
Anzeige:

Die Seite empfehlen

_

Hosttalk Logo
© by hosttalk.de
Powered by hosttest.de